Line | |
---|
1 | # package https://github.com/tahoe-lafs/txi2p |
---|
2 | # |
---|
3 | # if you need to update this package to a new txi2p release then |
---|
4 | # |
---|
5 | # 1. change value given to `buildPythonPackage` for `version` to match the new |
---|
6 | # release |
---|
7 | # |
---|
8 | # 2. change the value given to `fetchPypi` for `sha256` to `lib.fakeHash` |
---|
9 | # |
---|
10 | # 3. run `nix-build` |
---|
11 | # |
---|
12 | # 4. there will be an error about a hash mismatch. change the value given to |
---|
13 | # `fetchPypi` for `sha256` to the "actual" hash value report. |
---|
14 | # |
---|
15 | # 5. if there are new runtime dependencies then add them to the argument list |
---|
16 | # at the top. if there are new test dependencies add them to the |
---|
17 | # `checkInputs` list. |
---|
18 | # |
---|
19 | # 6. run `nix-build`. it should succeed. if it does not, seek assistance. |
---|
20 | # |
---|
21 | { fetchPypi |
---|
22 | , buildPythonPackage |
---|
23 | , parsley |
---|
24 | , twisted |
---|
25 | , unittestCheckHook |
---|
26 | }: |
---|
27 | buildPythonPackage rec { |
---|
28 | pname = "txi2p-tahoe"; |
---|
29 | version = "0.3.7"; |
---|
30 | |
---|
31 | src = fetchPypi { |
---|
32 | inherit pname version; |
---|
33 | hash = "sha256-+Vs9zaFS+ACI14JNxEme93lnWmncdZyFAmnTH0yhOiY="; |
---|
34 | }; |
---|
35 | |
---|
36 | propagatedBuildInputs = [ twisted parsley ]; |
---|
37 | checkInputs = [ unittestCheckHook ]; |
---|
38 | pythonImportsCheck = [ "parsley" "ometa"]; |
---|
39 | } |
---|
Note: See
TracBrowser
for help on using the repository browser.