source: trunk/nix/tahoe-lafs.nix

Last change on this file was f979efb, checked in by meejah <meejah@…>, at 2024-12-14T09:13:08Z

update nix version

  • Property mode set to 100644
File size: 1.4 KB
Line 
1let
2  pname = "tahoe-lafs";
3  version = "1.20.0.post1";
4in
5{ lib
6, pythonPackages
7, buildPythonPackage
8, tahoe-lafs-src
9}:
10buildPythonPackage rec {
11  inherit pname version;
12  pyproject = true;
13  src = tahoe-lafs-src;
14  propagatedBuildInputs = with pythonPackages; [
15    attrs
16    autobahn
17    cbor2
18    click
19    collections-extended
20    cryptography
21    distro
22    eliot
23    filelock
24    foolscap
25    future
26    hatchling
27    hatch-vcs
28    klein
29    magic-wormhole
30    netifaces
31    psutil
32    pyyaml
33    pycddl
34    pyrsistent
35    pyutil
36    six
37    treq
38    twisted
39    werkzeug
40    zfec
41    zope_interface
42  ] ++
43  # Get the dependencies for the Twisted extras we depend on, too.
44  twisted.passthru.optional-dependencies.tls ++
45  twisted.passthru.optional-dependencies.conch;
46
47  # The test suite lives elsewhere.
48  doCheck = false;
49
50  passthru = {
51    extras = with pythonPackages; {
52      tor = [
53        txtorcon
54      ];
55      i2p = [
56        txi2p-tahoe
57      ];
58      unittest = [
59        beautifulsoup4
60        html5lib
61        fixtures
62        hypothesis
63        mock
64        prometheus-client
65        testtools
66      ];
67      integrationtest = [
68        pytest
69        pytest-twisted
70        paramiko
71        pytest-timeout
72      ];
73    };
74  };
75
76  meta = with lib; {
77    homepage = "https://tahoe-lafs.org/";
78    description = "secure, decentralized, fault-tolerant file store";
79    # Also TGPPL
80    license = licenses.gpl2Plus;
81  };
82}
Note: See TracBrowser for help on using the repository browser.